University of Missouri
IT System Status
Outlook Mail Mobile Application
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 03, 2020 - 08:51 CDT
Identified
Mobile devices using the Outlook mobile app may have problems syncing new messages. Technicians are working on a resolution.
The default mail apps on mobile devices is not experiencing this issue.
Posted Feb 10, 2020 - 14:36 CST
This incident affected: Faculty/Staff Email and Student Email.