University of Missouri
IT System Status

Extension.missouri.edu

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 09:01 CDT

Monitoring

The Extension website has been restored and technicians are monitoring.
Posted Jun 17, 2026 - 20:11 CDT

Identified

The extension.missouri.edu website is currently experiencing an outage. University staff and a vendor are working on restoring services.
The estimated time to resolution is unknown.
Posted Jun 17, 2026 - 12:34 CDT
This incident affected: Other MU IT Services.