University of Missouri
IT System Status
Cherwell Client is experiencing an outage.
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted May 18, 2023 - 12:13 CDT
Investigating
Cherwell Client is experiencing an outage. Technicians are working to resolve the issue. The Cherwell Portal is still up and running.
Posted May 18, 2023 - 11:54 CDT
This incident affected: Other MU IT Services and Other UM IT Services.