University of Missouri
IT System Status
MS 365 Teams Calendar Integration
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 17:26 CDT
Monitoring
The system should be functioning properly, but please contact the IT Help Desk at 573.882.5000 if there are further issues.
Posted Jul 31, 2020 - 09:46 CDT
Investigating
The Exchange Messaging team has received reports that some users cannot view their Calendar within Teams and may receive an error stating “Couldn't load your calendar”. The team has opened a case with Microsoft and will provide additional updates once more information is provided by the vendor.
Posted Jul 30, 2020 - 11:04 CDT
This incident affected: Other MU IT Services and Other UM IT Services.