University of Missouri
IT System Status

MUHealthcare internet connectivity issues

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 11:49 CST

Investigating

Multiple MUHealthcare customers have reported inability to access multiple internet sites. Networking staff is investigating.
Posted Feb 23, 2026 - 11:10 CST
This incident affected: Other MU IT Services.