University of Missouri
IT System Status

Virtual Server Service

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 11:42 CST

Investigating

A hypervisor host in the service experienced an outage at 10:15 AM. Technicians are currently investigating the issue.
Posted Nov 20, 2025 - 10:40 CST
This incident affected: Other MU IT Services.