University of Missouri
IT System Status
MyView, Pathway, Joe'SS
Incident Report for UM IT Systems
Resolved
This service is now fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Feb 05, 2019 - 16:59 CST
Investigating
Some users are experiencing problems signing into MyView, Pathway, and Joe'SS. Technicians are investigating.
Posted Feb 05, 2019 - 16:57 CST
This incident affected: Joe'SS, MyView, and PATHway.