University of Missouri
IT System Status

MU Campus Cable Outage

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:28 CST

Monitoring

Service has been restored and will be monitored until the all-clear is given.
Posted Jan 22, 2026 - 14:46 CST

Update

Spectrum is continuing to troubleshoot. This is part of a larger issue affecting Missouri and southern Illinois.
Posted Jan 22, 2026 - 11:17 CST

Identified

The provider has been notified and technicians have been dispatched. No resolution estimate is available at this time.
Posted Jan 22, 2026 - 08:25 CST

Investigating

Areas of campus reporting Spectrum TV outage. Provider has been notified and is looking into the problem.
Posted Jan 22, 2026 - 03:11 CST
This incident affected: Other MU IT Services.