University of Missouri
IT System Status
Cherwell
Incident Report for UM IT Systems
Resolved
Cherwell is available again. Please report any ongoing issues to the DoIT Help Desk. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Nov 16, 2018 - 12:12 CST
Investigating
Some agents are observing degraded service when saving tickets. Technicians are looking into the issue to determine if there is a problem.
Posted Nov 16, 2018 - 11:47 CST
This incident affected: Other UM IT Services.