University of Missouri
IT System Status

Madison Street Family Medicine Clinic Network

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 08:12 CDT

Investigating

We are currently investigating this issue.
Posted Aug 27, 2025 - 07:35 CDT
This incident affected: Phone Services, TigerWiFi, and Wired Network.