University of Missouri
IT System Status
Identified issue with webapps.umsystem.edu menu
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 09:30 CDT
Investigating
The Division of IT is actively working on an issue related to webapps.umsystem.edu menu. Time to resolution is unknown at this time. Thanks for your patience.
Posted Oct 03, 2022 - 08:25 CDT
This incident affected: UM Web Applications.