University of Missouri
IT System Status

Cable Television

Incident Report for UM IT Systems

Update

Spectrum has identified a cut fiber affecting our service area. The current estimated time for restoration is 8 hours. Further updates will be provided when they are available.
Posted May 20, 2026 - 12:39 CDT

Identified

Spectrum has been contacted and they are aware of the issue. No ETA for restoration of services.
Posted May 20, 2026 - 11:23 CDT

Investigating

We are investigation an outage of cable TV services for the campus and hospital. We don't know of the cause at this time but continue to investigate.
Posted May 20, 2026 - 11:01 CDT
This incident affects: Other MU IT Services.