University of Missouri
IT System Status

Cloudflare Service Outage

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:52 CST

Investigating

Various internet services are down due to Cloudflare outage. For example, some services affected: CoPilot, ChatGPT, Gemini, Quizlet, and varies others sites.
Per Cloudflare, they continue to work on restoring service but no ETA at this time.
Posted Nov 18, 2025 - 08:16 CST
This incident affected: Other MU IT Services and Other UM IT Services.