University of Missouri
IT System Status
Cherwell Issues
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 14:40 CST
Investigating
We are experiencing log in issues with Cherwell and technicians are investigating.
Posted Feb 27, 2024 - 14:27 CST
This incident affected: Other MU IT Services and Other UM IT Services.