University of Missouri
IT System Status

TeamDynamix to replace Cherwell for Division of IT issues reporting & service requests

Incident Report for UM IT Systems

Resolved

TeamDynamix (TDX) is now live for Division of IT. Customers should now go to https://tdx.umsystem.edu/TDClient/36/DoIT/Home/ to report issues and request IT services and can refer to the FAQs article for general information on creating a ticket.
Posted Mar 24, 2025 - 07:41 CDT

Identified

Over the course of this weekend, the Division of IT will be working to switch over their IT ticketing application to TeamDynamix (TDX). This will be a replacement for Cherwell. More information will follow when TDX is live.
Posted Mar 21, 2025 - 16:41 CDT
This incident affected: Other MU IT Services and Other UM IT Services.