University of Missouri
IT System Status
Phone Services
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 09:22 CDT
Update
We are continuing to investigate this issue.
Posted Jul 30, 2024 - 09:22 CDT
Investigating
There is currently an issue with AT&T cellular customers contacting University phone numbers.
Posted Jun 22, 2024 - 12:19 CDT
This incident affected: Phone Services, Other MU IT Services, and Other UM IT Services.