University of Missouri
IT System Status

Milestone Updates

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Dec 22, 2025 - 17:24 CST

Investigating

Milestone is currently down to perform updates. Anticipated update time to be 2PM today
Posted Dec 22, 2025 - 09:21 CST
This incident affected: Other MU IT Services.