University of Missouri
IT System Status
Lync/Skype services
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted May 30, 2020 - 13:29 CDT
Investigating
Lync/Skype services are currently unavailable due to a vendor update. Technicians are investigating.
Posted May 30, 2020 - 11:39 CDT
This incident affected: Other MU IT Services.