University of Missouri
IT System Status

Network Services

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 20:02 CDT

Investigating

Some portions of campus are experiencing electrical issues that may affect network services. The issues are being investigated. Resolution time is currently unknown.
Posted Aug 15, 2026 - 18:18 CDT
This incident affected: Other MU IT Services and Wired Network.