University of Missouri
IT System Status

Networking Issues

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 19:13 CDT

Investigating

There have been multiple reports of issues accessing University webpages. Networking support staff are investigating the issues now.
Posted Sep 02, 2026 - 18:23 CDT
This incident affected: Other MU IT Services and Other UM IT Services.