University of Missouri
IT System Status
Cherwell
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted May 07, 2020 - 10:08 CDT
Identified
Cherwell is reporting degraded performance Amazon East. Users may experience slowness/degradation of service until the Amazon East service degradation is resolved.
Posted May 06, 2020 - 09:27 CDT
This incident affected: Other UM IT Services.