University of Missouri
IT System Status
VoiceThread page load failures
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Apr 02, 2020 - 18:49 CDT
Investigating
[Investigating] VoiceThread pages are not loading. Voicethread technicians are investigating and expect to have a resolution shortly.

https://voicethread.status.io/
Posted Apr 02, 2020 - 15:21 CDT
This incident affected: Canvas LMS.