University of Missouri
IT System Status

myVITA Evaluations error

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 14:56 CDT

Investigating

The faculty data and evaluation system myVITA is currently experiencing an error when navigating to Evaluations menu items for both faculty and administrators. All other pages of the site remain accessible. The site vendor’s engineering team is actively working on the issue. To receive notice on when the issue is fixed, faculty may reach out to ummyvita@umsystem.edu.
Posted Mar 31, 2025 - 09:38 CDT
This incident affected: Other MU IT Services and Other UM IT Services.