University of Missouri
IT System Status
Turnitin
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Apr 21, 2020 - 11:45 CDT
Investigating
Functionality of the Turnitin assignment tool in Canvas LMS is degraded. The vendor is working on a fix.
Posted Apr 21, 2020 - 10:01 CDT
This incident affected: Canvas LMS.