University of Missouri
IT System Status

MU Campus Web-hosting

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 17:54 CDT

Identified

The vendor responsible for hosting the majority of MU Campus Websites is currently experiencing an ongoing issue. This affects a portion of our websites, which may be unreachable until the incident is resolved.
Posted Apr 28, 2026 - 16:38 CDT
This incident affected: Other MU IT Services.