University of Missouri
IT System Status
Interfolio myVITA Login Issues
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact your local Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 09, 2020 - 14:15 CDT
Identified
The issue has been resolved for Chrome, but still persists with the Firefox browser. Here are updates from the vendor on additional links that can be used to work around the issue:
https://www.faculty180.com/sysadmin/login.php?dbID=umsystem or https://www.faculty180.com/?dbID=umsystem
Posted Jun 03, 2020 - 09:51 CDT
Investigating
The vendor is actively working on the issue. The current workaround for this is to close the browser out and try logging in again using this link: http://faculty180.interfolio.com/?dbID=umsystem.
Posted May 20, 2020 - 15:44 CDT
This incident affected: Other MU IT Services and Other UM IT Services.