University of Missouri
IT System Status

VoIP problems

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 06:27 CST

Investigating

Issues have been reported that are affecting the VoIP phone system and causing phones to reregister. Technicians are investigating.
Posted Feb 10, 2026 - 11:59 CST
This incident affected: Phone Services.