University of Missouri
IT System Status
myVITA outage
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 09:09 CDT
Investigating
The UM myVITA team has discovered an outage to the site starting today around 1:30pm. The vendor for this software, Interfolio, has been notified and are actively working on the issue. The login issue is also affecting all browsers.
The vendor is actively working on the issue.
Posted Apr 08, 2021 - 14:53 CDT
This incident affected: Other UM IT Services.