University of Missouri
IT System Status
Cherwell Log In Issue
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 21, 2020 - 11:05 CDT
Investigating
Unable to log into Cherwell at this time.
Technicians are looking into the cause and will send update when they are available.
Posted Jun 21, 2020 - 07:58 CDT
This incident affected: Other MU IT Services.