University of Missouri
IT System Status

Microsoft MFA issues

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 17:15 CDT

Monitoring

Intermittent phone authentication issues are still being observed but it is functional for most users. If you are having these issues please call the help desk for further investigation.
Posted Mar 11, 2025 - 11:06 CDT

Investigating

There are currently intermittent authentication issues with text and phone MFA. Technicians are investigating the cause and recommend setting up the Microsoft authentication app to avoid interruptions. We apologize for the inconvenience
Posted Mar 07, 2025 - 18:50 CST
This incident affected: Other MU IT Services and Other UM IT Services.