University of Missouri
IT System Status
Telecom Services Finesse Users
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Aug 07, 2024 - 12:20 CDT
Monitoring
Technicians have taken corrective action. They will continue to monitor the service performance and ask that any customer issues be reported to the Help Desk at 573.882.5000 or by clicking the chat button at doit.missouri.edu during business hours.
Posted Jul 18, 2024 - 13:07 CDT
Investigating
Finesse users are currently experiencing connection issues. The Finesse platform will be restarted and services will be affected while users are failing over to the backup servers.
Posted Jul 18, 2024 - 09:18 CDT
This incident affected: Phone Services.