University of Missouri
IT System Status

Campus cable outage

Incident Report for UM IT Systems

Update

Spectrum is indicating that the problem is a fiber cut. No ETA is given for the repair.
Posted Aug 11, 2026 - 10:59 CDT

Identified

Area wide outage reported by Spectrum. Technicians are working to fix the problem.
Posted Aug 11, 2026 - 10:28 CDT

Investigating

Campus cable TV is out for both campus and hospital. Problem is being investigated by outside vendor.
Posted Aug 11, 2026 - 10:09 CDT
This incident affects: Other UM IT Services.