University of Missouri
IT System Status
Titanium Schedule Unavailable
Incident Report for UM IT Systems
Resolved
Titanium Schedule is available and functioning normally.
Posted Jul 21, 2024 - 19:47 CDT
Investigating
Titanium Schedule is unavailable. Technicians have been notified and are investigating.
Posted Jul 21, 2024 - 17:03 CDT
This incident affected: Other MU IT Services and Other UM IT Services.