University of Missouri
IT System Status

AIMS Password Reset

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 19:17 CDT

Investigating

There is currently an issue with resetting account passwords within the AIMS self-service interface. Technicians are currently investigating the issue.
Posted Mar 24, 2025 - 17:16 CDT
This incident affected: Other MU IT Services and Other UM IT Services.