University of Missouri
IT System Status

Connectivity Issues

Incident Report for UM IT Systems

Monitoring

We've currently implemented a fix and the problem is resolved.
Technicians have identified the root cause of the issue and have implemented a fix across all systems. All previously impacted servers and services are now reporting healthy, but we will continue to monitor to ensure stability.
Posted Jun 11, 2026 - 10:51 CDT

Investigating

We are currently investigating an issue impacting some servers and services, including intermittent connectivity problems.
Mitigation steps have been applied and we are actively working to ensure all systems return to a stable state.
We will provide additional updates as more information becomes available.
Posted Jun 11, 2026 - 10:31 CDT
This incident affects: Other MU IT Services.