University of Missouri
IT System Status

Cisco Finesse problem

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 08:13 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 01, 2026 - 11:16 CST

Investigating

Several people have reported that Cisco Finesse is having issues at the MU Hospital. Techs are looking into the problem now.
Posted Mar 01, 2026 - 10:12 CST
This incident affected: Other MU IT Services, Other UM IT Services, and UM Web Applications.