University of Missouri
IT System Status

Hellbender Outage

Incident Report for UM IT Systems

Monitoring

The cooling network is back online now. Nodes are being powered back on in waves. The cooling network is now running on our old Coolant Distrubution Unit (CDU), and we will likely need repairs done on the newer CDU which was having the work done on it today.
Posted Jul 16, 2026 - 12:44 CDT

Identified

We have a contractor on site servicing our liquid cooling network. Unfortunately, there was a temporary blip in the cooling system which caused all of our liquid cooled nodes to power off due to overheating. We are working on bringing the coolant network and these nodes back online.
Posted Jul 16, 2026 - 12:10 CDT
This incident affects: Other MU IT Services and Other UM IT Services.