University of Missouri
IT System Status

Power outages: Hill and Lemone/Maguire Campus Network Unavailable

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 15:25 CDT

Update

Update: Power and network services is restored at Hill Hall. Power and network is still down on Lemone and Maguire.
Posted Apr 27, 2026 - 12:27 CDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 27, 2026 - 11:27 CDT

Identified

There are power outages at Hill Hall and at 2910 Lemone and 2800 Maguire (ARC, FRTI, PrintingServices, Records and Press, Library Depository). These locations have no internet connectivity. There is no ETA, but Networking is monitoring the equipment status.
Posted Apr 27, 2026 - 11:26 CDT
This incident affected: Phone Services, TigerWiFi, and Wired Network.