University of Missouri
IT System Status

AIMS Licensing Issue

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 12:23 CDT

Identified

An issue was identified when users were identified incorrectly for removing their Microsoft license. Technicians are working to resolve the issue quickly.
Posted Jun 19, 2025 - 09:54 CDT
This incident affected: Other MU IT Services and Other UM IT Services.