University of Missouri
IT System Status

Telecom Services

Incident Report for UM IT Systems

Resolved

This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jul 25, 2026 - 09:20 CDT

Investigating

Calabrio call recording is unavailable for campus and hospital voip subscriber and contact centers. Technicians are working to restore service; there is no ETA at this time.
Posted Jul 24, 2026 - 18:27 CDT
This incident affected: Other MU IT Services, Other UM IT Services, and Phone Services.