University of Missouri
IT System Status
Cherwell Status message
Incident Report for UM IT Systems
Resolved
Cherwell performance is now back to normal.
If you continue to see issues, please contact the help desk.
Posted Jan 21, 2021 - 12:03 CST
Investigating
Cherwell is experiencing some degradation in service.
You may see slow performance or intermittent disruptions in
Service. Technicians are looking into the issue and will update as needed.
Posted Jan 21, 2021 - 10:57 CST
This incident affected: Other MU IT Services and Other UM IT Services.