University of Missouri
IT System Status
High Volume of Incoming Robocalls
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Sep 13, 2018 - 14:05 CDT
Investigating
We are intermittently experiencing a high volume of ‘robocalls’ from a legitimate Chicago area code and exchange (312-803-xxxx). We have been informed the content of these calls and voicemails are in Mandarin Chinese. Technicians are aware of the problem and are currently investigating a mitigation path.
Posted Sep 10, 2018 - 16:03 CDT
This incident affected: Phone Services.