University of Missouri
IT System Status
Phone Lines
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted May 23, 2023 - 09:21 CDT
Investigating
Phones are being affected by a circuit down in the telecom datacenter due to a cut fiber between here and Kansas City, Vendor is working on the repair.
Posted May 22, 2023 - 15:59 CDT
This incident affected: Phone Services.