University of Missouri
IT System Status

TeamDyanmix (TDX) email communication delay/issues

Incident Report for UM IT Systems

Resolved

This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 17, 2025 - 08:21 CDT

Update

The email issues and delays associated with TeamDynamix (TDX) have been identified as affecting only the Academic Technology TDX Applications. Technicians are actively investigating the matter and will share updates as they become available.
Posted Oct 10, 2025 - 16:36 CDT

Identified

TeamDynamix (TDX) is currently experiencing email issues and delays. Technicians are actively investigating the problem and will provide updates as they become available. The estimated time to resolution is unknown.
Posted Oct 10, 2025 - 12:18 CDT
This incident affected: IT Ticketing Application (TeamDynamix).