University of Missouri
IT System Status

offcampus.missouri.edu down

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 08:57 CDT

Investigating

offcampus.missouri.edu certificate is currently expired
We're working with the third-party vendor that powers this site to supply us with the proper renewed certificate.
Posted Mar 18, 2026 - 17:17 CDT
This incident affected: Other UM IT Services.