University of Missouri
IT System Status

networking/DNS maintenance

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 17:33 CDT

Monitoring

We are performing urgent cross-system networking/DNS maintenance on our Active DIrectory domains, implementing additional security measures. This maintenance will occur between 1:45 and 2:30 PM with supervision and checks by representatives from all UM campuses and will be reverted swiftly if any issues are observed.
Posted Sep 11, 2026 - 13:57 CDT
This incident affected: Other MU IT Services and Other UM IT Services.