University of Missouri
IT System Status

MU Connect

Incident Report for UM IT Systems

Resolved

MU Connect has been restored and is functioning as expected. Please let us know at muconnectsupport@missouri.edu if you see any issues or concerns.
Posted Aug 07, 2026 - 11:33 CDT

Identified

The MU Connect system is currently experiencing issues related to duplicate Appointment Alert emails, "bad gateway" messages, page timeouts, and more. This is a vendor-wide issue, and technicians are actively working to resolve it. While they investigate, they have temporarily paused various system processes for all sites which may impact email delivery, calendar syncs, and other processes may be delayed. The estimated time to resolution is unknown.
Posted Aug 07, 2026 - 09:28 CDT
This incident affected: MU Connect.