University of Missouri
IT System Status

Mobile ID Issuance

Incident Report for UM IT Systems

Monitoring

Vendor has identified and put remediation in place, actively monitoring.
Posted Aug 22, 2026 - 19:04 CDT

Investigating

Investigating – reported issues with provisioning of mobile ID, services are degraded, current mobile IDs do not appear to be impacted. Vendor is investigating.
Posted Aug 22, 2026 - 12:54 CDT
This incident affects: Other MU IT Services.