University of Missouri
IT System Status
Canvas/Box Integration
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Sep 05, 2019 - 13:37 CDT
Investigating
At the moment, the integration between Canvas and Box is presenting an error message to the user. There is no ETA on a fix, but we are actively working on it.
Posted Sep 05, 2019 - 10:11 CDT
This incident affected: Canvas LMS and Other MU IT Services.