University of Missouri
IT System Status

Pharos Printing Issues

Incident Report for UM IT Systems

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2025 - 12:16 CST

Investigating

Multiple users have reported issues with Faculty/Staff printing. We are currently investigating.
Posted Dec 16, 2025 - 09:51 CST

Monitoring

Faculty/Staff are printing now, and we are monitoring the situation
Posted Dec 15, 2025 - 22:03 CST

Investigating

Multiple users have reported issues with Faculty/Staff printing. We are currently investigating.
Posted Dec 15, 2025 - 15:07 CST
This incident affects: Other MU IT Services.